LAST CHANCE: Save 50% on all my Swift books and bundles! >>

[Solved] Help needed to solve rejection of app for TestFlight

Forums > macOS

Hey guys,

as if it wasn't hard enough to develop an app, I now struggle with the rejection by apple of my app, that I submitted for Testflight. ;)

I developed a macOS menu bar app and distrubuted it to AppConnect. My developer account is part of the internal test group and when I login TestFlight on my development system, the app shows up, I install it and it runs as indendet.

So I generated an Invitation link for external testers. Now the Apple team checks the app first. The app was beeing rejected:

The app fails to launch. No error message or crash logs produced. To clarify, when we attempt to open the app from the applications folder, nothing happens. The app does not open and does not show up in activity monitor at all. If you are unable to reproduce this issue, ensure you are testing the exact version of the app that you submitted for review, and that you're doing so in a minimally privileged environment.

They provided me two links to Q&A's that I'm a bit owerwhelmed with. So I tested the app on the guest user account on both of my iMac (Intel) and macBook pro (M1) - logged into TestFligt wirth my dev apple id, installed the app. And it runs.

How can I reproduce the problem or debug? Could someone take me by the hand and guide me please cause im totally lost :)

Thanks a lot! Harry


Firstly do not get down over a rejection of an app (see my post App Review).

Is the build on Connect the same as the one use are testing? - Try uploading a new build, just change the build number not version.

Have you opened it from the "Applications folder" on your Mac? (Not from Xcode).


Thanks for your quick reply! And thanks for sharing your jouney! I hope my app doesn't need as long to be on the app store! ;)

Is the build on Connect the same as the one use are testing?

It's the build that I installed via TestFlight

Have you opened it from the "Applications folder" on your Mac?

That's something I hadn't tested before. So I just now tried to start the app from the app from the applications folder (logged in as guest user). 1st double click: nothing, 2nd doube click: nothing and so on. Then I tried to start it via spotlight and: app launches. And from then on, the app also launched from a double click. Problem: I can't "go back" - it just works now. Even after log out and restart of the machine. It'works.

On my iMac: worked from the first double click (also guets user account).

Can I solve this weird behavior?

Thanks Harry


I forgot to mention: source code is on GitHub if that helps:


To get an app approved , in once case it took 2 months and more then 19 revisions, welcome aboard, i hope this will not be the case with your app. Just a few tips for app approval.

1) Make sure you choose the right age category for app

2) Make sure you have a privacy policy.

3) Make sure if you are storing any user data be honest about it.

4)They will ask you questions about the ad netwrok you are using , if any , be prepared to answer that.

5)Be prepared if they ask you to provode an option to the user to delete their data if they want.

6)Be prepared if they ask you to remove some words or options from your app.

7) If they say your app is crashing , trust me it must be crashing, please check again at your end. They really want to help you not hinder you.

And finally always be respectful in your replies.



Thanks for your really useful tipps! I'll try to regard every single topic upfront.

Yeah, the app was definately crashing. But for me as a total noob with no experience in debugging outside of Xcode it's totally overwhelming. How can I reproduce the crash (it was running perfectly on my developer account)? What's the reason? Which of the console messages do matter? And if, what to make them disappear? And so on. I think a finally found the "failure". Simply by very time consuming trial and error ... ;) So: one step further on my way to the App Store! ;)

Thanks Harry


I think I found the "failure" - the app starts now on a gust user account without crashing and the review team didn't complain eather ... ;)

For anyone googling, here is my "solution":

In the guest user account in console, I got a message containing "prompting policy for hardened runtime ktccserviceAppleevents requires entitlement" (I can't reproduce the original message).

Well, I had to check "Apple Events" (is it an entitlement?) in the "Hardened Runtime" section of Signing&Capabilities. I don't know why because my app doesn't want to "psot AppleEvents to other applications" but .... it works. :)

Thanks all Harry


Hacking with Swift is sponsored by Essential Developer.

SPONSORED Join a FREE crash course for mid/senior iOS devs who want to achieve an expert level of technical and practical skills – it’s the fast track to being a complete senior developer! Hurry up because it'll be available only until July 28th.

Click to save your free spot now

Sponsor Hacking with Swift and reach the world's largest Swift community!

Archived topic

This topic has been closed due to inactivity, so you can't reply. Please create a new topic if you need to.

All interactions here are governed by our code of conduct.

Unknown user

You are not logged in

Log in or create account

Link copied to your pasteboard.