UPGRADE YOUR SKILLS: Learn advanced Swift and SwiftUI on Hacking with Swift+! >>

Preview Crashes

Forums > SwiftUI

I am new to Swift. Going through the iTour tutorial. Preview crashes when trying to preview my app. When I reopen the application I get the message " You can't use this version of the application "iTour" with this version of macOS." I had to update my version of macOS yesterday while going through the tutorial for iTour. Updated to Sonoma 14.3.1. I am running Xcode version 15.2. I only got through the Querying SwiftData objects in SwiftUI portion of the tutorial. Since I updated macOS while writing the app and started a new app and have the same results. How do I resolve the error message?

   

Have a look at this thread. It "might" help.

forums.developer.apple.com/forums/thread/726838

Steve

   

Hacking with Swift is sponsored by Essential Developer

SPONSORED Join a FREE crash course for mid/senior iOS devs who want to achieve an expert level of technical and practical skills – it’s the fast track to being a complete senior developer! Hurry up because it'll be available only until April 28th.

Click to save your free spot now

Sponsor Hacking with Swift and reach the world's largest Swift community!

Reply to this topic…

You need to create an account or log in to reply.

All interactions here are governed by our code of conduct.

 
Unknown user

You are not logged in

Log in or create account
 

Link copied to your pasteboard.