NEW: My new book Pro SwiftUI is out now – level up your SwiftUI skills today! >>

Disable rotation?

Forums > SwiftUI

My app is built to support Portrait mode only, but the views still auto rotate to landscape.

Is there a way to fix or override this behaviour?

Or is this a bug in xcode 13?

Thanks.

2      

Go it the main and select TARGETS then select Info tab (the plist) and open Supported inferface orientations (iPhone) the click on the ones that you do not need. Just leave Portrait(bottom home button). That should make the UI stay one way.

3      

Turns out the build settings have the orientation twice for some reason. The second one with " Supported inferface orientations (iPhone)" still have landscape included. After I removed that things worked.

2      

Hacking with Swift is sponsored by Play

SPONSORED Play is the first native iOS design tool created for designers and engineers. You can install Play for iOS and iPad today and sign up to check out the Beta of our macOS app with SwiftUI code export. We're also hiring engineers!

Click to learn more about Play!

Sponsor Hacking with Swift and reach the world's largest Swift community!

Archived topic

This topic has been closed due to inactivity, so you can't reply. Please create a new topic if you need to.

All interactions here are governed by our code of conduct.

 
Unknown user

You are not logged in

Log in or create account
 

Link copied to your pasteboard.