NEW: Learn to build the incredible iOS 15 Weather app today! >>

Server-Side Vapor Edition - Trouble opening Xcode in project1

Forums > Server-side Swift

Hi, I am following along with my recent book purchase. After building project1 and changing directory to project1 I keep getting errors on vapor build and vapor run.

.backgroundExecute(..... error: unable to find utility \"xctest\", not a developer tool or in PATH\n \n", output: "").

On the Vapor3 Discord site there is some mention of this error but they were easily solved by downloading xCode. I already have xcode, have used swift packages before (not executable). I think this is a command line issue finding and connecting but not sure how to approach.

FYI. I was able to open xcode from the project and run the basic routes to contact and staff but started running into issues with finding the leaf files. I believe this issue is connected to the vapor being able to run.

Please advise, Thanks Tom

   

Hacking with Swift is sponsored by Essential Developer

SPONSORED Only until this Sunday, December 12th, you can join a free crash course to learn advanced techniques for testing new and legacy Swift code — it's the fast track to becoming a complete Senior iOS Developer!

Click to learn more

Sponsor Hacking with Swift and reach the world's largest Swift community!

Archived topic

This topic has been closed due to inactivity, so you can't reply. Please create a new topic if you need to.

All interactions here are governed by our code of conduct.

 
Unknown user

You are not logged in

Log in or create account
 

Link copied to your pasteboard.