NEW: Start my new Ultimate Portfolio App course with a free Hacking with Swift+ trial! >>

SOLVED: IOS 14.2

Forums > SwiftUI

Yesterday I updated my iPhone and iPad to IOS 14.2 and now XCode 12.1 says that their configuration is unsupported.

XCode 12.2 is in beta, so I prefer not to install that.

My question is, does this sort of situation occur often, should I not update my devices to the latest version of IOS until the Xcode version has been updated?

   

From time to time yes... It usually takes max a few days until new Xcode is ready.

I am pretty conservative when it comes to updates. Especially these minor versions usually dont have anything that you need to have ASAP. But I understand that someones wants to upgrade on a day one.

There are ways to deploy from older Xcode to newer version, but are not trivial and not worth it in my opinion.

   

thanks Filip, I usually upgrade as soon as its available, but i guess if i want to deploy to my own devices i need to be sure that Xcode has always been updated first.

   

Paul tweeted this link click on it and will open the App store to able update

https://apps.apple.com/gb/app/xcode/id497799835?mt=12

Hope that helps

   

Hacking with Swift is sponsored by RevenueCat

SPONSORED Building and maintaining in-app subscription infrastructure is hard. Luckily there's a better way. With RevenueCat, you can implement subscriptions for your app in hours, not months, so you can get back to building your app.

Try it for free

Sponsor Hacking with Swift and reach the world's largest Swift community!

Reply to this topic…

You need to create an account or log in to reply.

All interactions here are governed by our code of conduct.

 
Unknown user

You are not logged in

Log in or create account
 

Link copied to your pasteboard.