NEW: Subscribe to Hacking with Swift+ and accelerate your learning! >>

Firestore pod failing after update

Forums > Swift

I recentlly updated my pod files (pod update) which i have for over a year with my app.

I am now getting this error

ld: framework not found FirebaseInstanceID

I understand it cannot find this by framework, I am unsure why this would occur ?

I update my pods often, so the version my have been upgraded to 6.20 or 6.19 from the 6.18 version, I cannot see what would cause this breaking change.

My pods are shown below for reference, i'm developing for ios 13.1

pod 'Firebase/Analytics'
pod 'Firebase/Firestore'
pod 'Firebase/Auth'
pod 'Firebase/Storage'
pod 'Fabric', '~> 1.10.2'
pod 'Crashlytics', '~> 3.14.0'
pod 'Firebase/Functions'

I have removed all derived data multiple times, tried different devices, running the latest xcode of 11.3.1

Any ideas on what to try next? Thanks


Maybe try adding it through the build in package manager ? See if that changes anything (Xcode 11)


Firebase isnt able to use SPM yet ...

I just tried a full removal of the pods using

cocoapods-deintegrate cocoapods-clean

No luck, but i added a package (that I dont need) which i know contains FirebaseInstanceID

pod 'Firebase/Messaging'

Now it works, looks like they removed FirebaseInstanceID from where I was accessing it before because my pod file has never change


I can confim ths happened to me

Downloading dependencies
Installing DeviceGuru 6.0.4 (was 6.0.3 and source changed to `` from `trunk`)
Installing Eureka 5.2.1 (was 5.1.0 and source changed to `` from `trunk`)
Installing Firebase 6.21.0 (was 6.14.0)
Installing FirebaseAnalytics 6.4.0 (was 6.1.7 and source changed to `` from `trunk`)
Installing FirebaseCore 6.6.5 (was 6.5.0 and source changed to `` from `trunk`)
Installing FirebaseCoreDiagnostics 1.2.2 (was 1.1.2 and source changed to `` from `trunk`)
Installing FirebaseCoreDiagnosticsInterop 1.2.0 (was 1.1.0 and source changed to `` from `trunk`)
Installing FirebaseInstallations (1.1.1)
Installing GoogleAppMeasurement 6.4.0 (was 6.1.7 and source changed to `` from `trunk`)
Installing GoogleDataTransport 5.1.0 (was 3.2.0 and source changed to `` from `trunk`)
Installing GoogleDataTransportCCTSupport 2.0.1 (was 1.2.3 and source changed to `` from `trunk`)
Installing GoogleUtilities 6.5.2 (was 6.4.0)
Installing MarqueeLabel 4.0.2 (was 4.0.0 and source changed to `` from `trunk`)
Installing PromisesObjC (1.2.8)
Installing ViewRow 0.8
Installing ZendeskSDK 4.0.1 (was 4.0.0 and source changed to `` from `trunk`)
Removing FirebaseInstanceID
Generating Pods project
Integrating client project
Pod installation complete! There are 13 dependencies from the Podfile and 25 total pods installed.

[!] ZendeskSDK has been deprecated in favor of ZendeskSupportSDK
MacBook-Pro:ios-prem admin$ nano Podfile
MacBook-Pro:ios-prem admin$ pod install
Analyzing dependencies
Downloading dependencies
Installing Firebase 6.21.0
Installing FirebaseAnalyticsInterop (1.5.0)
Installing FirebaseInstanceID (4.3.2)
Installing FirebaseMessaging (4.3.0)

I added Firebase/messaging and it works

this was the line of code that said "undefined identifier InstanceID" was not able to fix it using Firebase/Core alone

        InstanceID.instanceID().instanceID { (result, error) in
                if let error = error {
                    print("Error fetching remote instange ID: \(error)")
                else if let result = result {
                    Globals.Values.FCMToken = result.token


I had the same issue and posted it on Github. Here's the cause and the fix:


Hacking with Swift is sponsored by NSSpain

SPONSORED Announcing NSSpain 2020: Remote Edition! An online, continuous conference for iOS developers. We’ll start on Thursday and finish on Friday, with talks, activities, and lots of fun for 36 hours, non-stop. Sound good? Join us!

Find out more

Sponsor Hacking with Swift and reach the world's largest Swift community!

Reply to this topic…

You need to create an account or log in to reply.

All interactions here are governed by our code of conduct.

Unknown user

Not logged in

Log in

Link copied to your pasteboard.