UPGRADE YOUR SKILLS: Learn advanced Swift and SwiftUI on Hacking with Swift+! >>

Project 1: Designing Interface Part 3, Simulator shows a white screen

Forums > 100 Days of Swift

Hi

I'm currently doing the 1st Project of 100 days of Swift

At this part: https://www.hackingwithswift.com/read/1/3/designing-our-interface

If I run the build, all I get is still a white screen, instead of the Table View

As you can see in the picture, I think there is some sort of error, the Console spins forever.

See a screenshot https://imgur.com/a/EqRjnrv

I have followed all the steps in the course, so not sure what is wrong.

Anyone knows how to troubleshoot this?

Thank you

3      

Have you done this

This project is all about letting users select images to view, so you're going to need to import some pictures. Download the files for this project from GitHub (https://github.com/twostraws/HackingWithSwift), and look in the “project1-files” folder. You'll see another folder in there called Content, and I’d like you to drag that Content folder straight into your Xcode project, just under where it says "Info.plist".

Tip: If you’re not sure what to download, use this link: https://github.com/twostraws/HackingWithSwift/archive/main.zip – that’s the zip file for all my project files.

If not then make sure you do Setting up otherwise you have no data to work with!

3      

Hi Nigel.

Yes, I have added the images as you can see, just like in the tutorial

https://imgur.com/a/sMckrpm

The code is correct too.

But still, the view I see in the Storyboard (an empty, scrollable table) is not populated when I run the build.

3      

did it print out the images names in console?

you need to do the next step as you are missing the code for the table view

Designing our interface

3      

Hi Nigel

Yes it does print the image names.

I went up until this part where Paul says when I build the app, I should see a table view instead of a white screen, but I still see a white screen

https://youtu.be/0hMgOfF8tyQ?t=545

When I close the Simulator it gives a crash message so something seems wrong but I do not know what

3      

I can now see the table, only after I added the cells

https://imgur.com/a/leFlNHG

So Xcode doesn't show an empty table like in Paul's video, this is where I thought I had something wrong.

So the problem is solved now, thank you

4      

Hacking with Swift is sponsored by Essential Developer

SPONSORED Join a FREE crash course for mid/senior iOS devs who want to achieve an expert level of technical and practical skills – it’s the fast track to being a complete senior developer! Hurry up because it'll be available only until April 28th.

Click to save your free spot now

Sponsor Hacking with Swift and reach the world's largest Swift community!

Archived topic

This topic has been closed due to inactivity, so you can't reply. Please create a new topic if you need to.

All interactions here are governed by our code of conduct.

 
Unknown user

You are not logged in

Log in or create account
 

Link copied to your pasteboard.